Node Packets not appearing on LoRa App Server


#1

I have Lora Server running in Kubernetes on Google Cloud Platform. I have a new node (Node-B) activated using ABP. Transmissions from this node are received maybe 2-3 times at the server but after that they cease to appear. I can confirm the packets arrive the gateway but they never show up on the server.
No incident shows up in the server logs and being a docker container I am not sure how to gain better visibility into the container.
Transmissions from another device (Node-A) using the same gateway arrive the LoRa Server without issues. This other device has Disable frame-counter validation set. However, when i try to set this option on the new device it doesn’t save. When I save, I can see from the Lora app server logs that the settings were updated
time=“2018-05-08T20:26:24Z” level=info msg=“device updated” dev_eui=1122334455667788
Q1. How can I trace and resolve this?
Q2. What could cause “Disable frame-counter validation” not to work?


#2

Is this not related to any of these issues? https://forum.loraserver.io/search?q=invalid%20mic


#3

I couldn’t find any related to it. Intermittently, frames from the node show up on Lora App Server Live Event Log. At those times I am able to receive them over MQTT and the transmissions show up in the logs.

However, when the frames stop appearing in the Live Event Logs, there is no error report in the Lora App Server logs nor in the Loraserver logs.I didn’t check the Lora Gateway Bridge logs. Perhaps I should. I have each of the components running in different pod.

Also what could prevent disable frame counter setting from being set after a save?


#4

I have been able to solve the problem. The issue was the version of loraserver running. I stated the container on 11 April but a change made after that added the “SkipFcntCheck” option.

Deleting the pod in kubernetes forced a new one to spin up with the most recent version and all is well. I had to reprovision the ABP node with “Disable Frame Counter” enabled.