Multiple instance of loraserver creates a lag in join accept

Hi,

I have set up a second loraserver for US band capabilities (my first was EU).
They are both working with the same lora-app-server with 2 separate network servers.

Everything is working fine, i was able to create gateway and device profile with the second loraserver and thus, they are working with US band.

However, when my EU devices are trying to connect to gateway, there is a lag in join request (gets a lot of join request to have a join accept, at least 3 or 4, up to 9). If I turn off the US loraserver, i get the join accept immediately from the EU loraserver.

Iā€™m assuming that there is a rejection of the EU device by the US loraserver (that i can see on logs) but why does it create a delay to get the join accept from the EU loraserver ?

Any idea on the configuration i may add/ change ?

Thanks

1 Like

Please make sure that each NS cluster has its own region prefix, eg:

  • eu868/gateway/....
  • us915/gateway/....

That way your US instance does not receive EU payloads and the other way around.

1 Like

Thanks for the reply.

In that case, my lora-gateway-bridge will not be able to find both mqtt topics (for example uplink_topic_template).
Can i specify in the configuration dynamic topic (for example ā€œ+/gateway/ā€¦ā€) or should i have 2 lora-gateway-bridge instance ?

Yes, you must have two instances in the case the LoRa Gateway Bridge is not installed on the gateway.

ok thank you i will implement that !