Lora-gateway-bridge.log on Multitech mLinux Conduit


#1

I am trying to debug some issues in my setup. I have packet forwarder and lora gateway bridge installed on my mLinux conduit. Frames are successfully making it to the network server. But I am having trouble with devices joining with OTAA.

To debug further I would like to look at the lora-gateway-bridge.log, which would be here:

/var/log/lora-gateway-bridge/lora-gateway-bridge.log

If this were a debian/ubuntu install.

However, I don’t have a any lora* directories under /var/log. I tried searching for all log files using

find -name *.log -print

And didn’t find anything.

What are the log files named on a conduit install. Do they need to be enabled?

In lora-gateway-bridge.toml I see that the default log level is info, 4, but I do not see any paths in there.

Here is what happens when I search for lora

root@mtcdt:/# find -name *lora*
./etc/rc0.d/K20lora-gateway-bridge
./etc/rc0.d/K20lora-packet-forwarder-usb
./etc/rc1.d/K20lora-gateway-bridge
./etc/rc1.d/K20lora-packet-forwarder-usb
./etc/rc2.d/S20lora-gateway-bridge
./etc/rc2.d/S20lora-packet-forwarder-usb
./etc/rc3.d/S20lora-gateway-bridge
./etc/rc3.d/S20lora-packet-forwarder-usb
./etc/rc4.d/S20lora-gateway-bridge
./etc/rc4.d/S20lora-packet-forwarder-usb
./etc/rc5.d/S20lora-gateway-bridge
./etc/rc5.d/S20lora-packet-forwarder-usb
./etc/rc6.d/K20lora-gateway-bridge
./etc/rc6.d/K20lora-packet-forwarder-usb
./etc/init.d/lora-packet-forwarder-usb
./etc/init.d/lora-gateway-bridge
./opt/lora-packet-forwarder-usb
./opt/lora-gateway-bridge
./opt/lora-gateway-bridge/lora-gateway-bridge
./run/lora-packet-forwarder-usb.pid
./run/lora-gateway-bridge.pid
./sys/devices/platform/mts-io/lora
./sys/devices/platform/mts-io/capability/lora
./var/lib/opkg/info/lora-gateway-bridge.conffiles
./var/lib/opkg/info/lora-gateway-bridge.control
./var/lib/opkg/info/lora-packet-forwarder-usb.list
./var/lib/opkg/info/lora-gateway-bridge.list
./var/lib/opkg/info/lora-packet-forwarder-usb.control
./var/config/lora-packet-forwarder-usb
./var/config/lora-gateway-bridge
./var/config/lora-gateway-bridge/lora-gateway-bridge.toml
./home/root/lora-gateway-bridge_2.4.0-r1.0_arm926ejste.ipk
./home/root/lora-packet-forwarder-usb_1.4.1-r2.0_arm926ejste.ipk

Best Regards,
Nick


#2

Hi Nick, the lora-gateway-bridge.ipk package for the Conduit does not store any logs. I’m not sure if that is a good idea as the available memory is limited. I believe the /var/log directory is mounted as a tmpfs which probably is stored in RAM (to not wear out the NAND flash).

For debugging you could stop the gateway bridge (/etc/init.d/lora-gateway-bridge stop) and then start it manually:

/opt/lora-gateway-bridge/lora-gateway-bridge -c /var/config/lora-gateway-bridge/lora-gateway-bridge.toml

#3

That did the trick, thanks!