LoRa Gateway Bridge Docker install


#1

Hi, I was wondering if anyone had a similar issue to what I’m coming across. Gave this a search but couldn’t seem to find anything. I am trying to build a docker image (on ARM platform) after updating to the newest version of LoRa App Server, LoRaServer, and LoRa Gateway Bridge. All seem to work correctly except for LoRa Gateway Bridge.

The error I get is during the “make dev-requirements” step of the Dockerfile

    go get -u github.com/goreleaser/goreleaser
    package github.com/kamilsk/retry/v3: cannot find package "github.com/kamilsk/retry/v3" in any of:
            /usr/local/go/src/github.com/kamilsk/retry/v3 (from $GOROOT)
            /go/src/github.com/kamilsk/retry/v3 (from $GOPATH)
    package github.com/kamilsk/retry/v3/backoff: cannot find package "github.com/kamilsk/retry/v3/backoff" in any of:
            /usr/local/go/src/github.com/kamilsk/retry/v3/backoff (from $GOROOT)
            /go/src/github.com/kamilsk/retry/v3/backoff (from $GOPATH)
    package github.com/kamilsk/retry/v3/strategy: cannot find package "github.com/kamilsk/retry/v3/strategy" in any of:
            /usr/local/go/src/github.com/kamilsk/retry/v3/strategy (from $GOROOT)
            /go/src/github.com/kamilsk/retry/v3/strategy (from $GOPATH)
    make: *** [Makefile:38: dev-requirements] Error 1

Trying “go get -u github.com/goreleaser/goreleaser” on my local machine has the same effect, so I was leaning towards this being an issue with goreleaser specifically.

These two issues mention that goreleaser should have precompiled binary. I’m wondering if this is an issue with my implementation or something else.



#2

Seems it was simply an issue with me not copying/updating certain files :pensive: Please ignore.


closed #3