Disable confirmed uplink server side or reduce amount of retries


#1

Currently I am facing a problem where I have a lot of devices at different locations sending many retries on confirmed uplink messages. For some reason the devices (based on a iM880A module and Class A devices): are not receiving their acknowledge on time any more.
This problem is getting worse and worse and now at some locations 90% of the messages that are transmitted are double messages… Which will lead to more traffic with higher Spreading factor making the problem bigger and draining the batteries of the sensors rapidly.

Over the last year the devices have been doing well, but in the last 2 months it is getting bad. In general I have always had some double message (20%). As far I know I haven’t changed a thing in the Lora Network.

The thing is that at different locations the gateways (Multitech Conduit) en devices are performing ok and I don’t have the double messages, but at other locations it is very bad. All the gateways have the same configuration files and the devices have the same firmware. If I look at the package forwarder on the gateways they say they have transmitted the acknowledge messages on time, but the sensor is not hearing them…

Anybody had this problem before? What is the best way to start debugging? What could be a possible cause for this behavior?

I have heard that it should be possible to disable the Confirmed uplink by sending an message over the Lora Network to the sensors. Or maybe change the retries from 8 to 2… Is this possible? And how do I set this up in the LoraServer configuration? It is not a solution to my cause of the problem, but makes sure that batteries will not drain so fast and maybe by reducing the air load the system gets back to normal.

Any idea tips on possible debugging possibilities are appreciated and I am also curios if and how I can disable confirmed uplink from the server…


#2

Maybe an obvious question, but why are you sending confirmed uplinks in the first place?


#3

Yes, a very good question. And maybe a bad choice. But a year ago we had the problem to miss many frames of uplink messages and enabled the confirmation. That brought a solution and helped us out to make sure that we received every sensor message.

Now we haave already a lot of devices and it is almost impossible to get every device back and change the firmware… So if we could disable the ack server side would be worth a try. Chances are I will start to miss messages again.