Could not handle packet


#1

Hello
I am a new to using iot and i have kerlink gateway indoor with ubuntu pc and i installed on my pc loraserver,lora-app-server and lora gateway bridge but i have this error in my loge file
log for lora server is
level=error msg=“update gateway state error” error=“handle gateway stats error: get channel error: lorawan/band: invalid channel”
level=info msg=“metrics saved” aggregation="[MINUTE HOUR DAY MONTH]" name=“gw:7276ff0039030a65”
level=info msg=“gateway/mqtt: uplink frame received”
level=info msg=“packet(s) collected” dev_eui=551e06feffe5a0cc gw_count=1 gw_ids=7276ff0039030a65 mtype=JoinRequest
level=info msg=“device-queue flushed” dev_eui=551e06feffe5a0cc
level=info msg=“device-session saved” dev_addr=01e41018 dev_eui=551e06feffe5a0cc
level=info msg=“device-activation created” dev_eui=551e06feffe5a0cc id=1545
level=info msg=“device updated” dev_eui=551e06feffe5a0cc
level=info msg=“gateway/mqtt: publishing downlink frame” qos=0 topic=gateway/7276ff0039030a65/tx
level=info msg=“downlink-frames saved” dev_eui=551e06feffe5a0cc token=25364
and log for lora app server is
msg=“js: sending response” message_type=JoinAns receiver_id=000000 result_code=Success sender_id=aabbccddeeff1122 transaction_id=870113427
msg=“js: request received” message_type=JoinReq receiver_id=aabbccddeeff1122 sender_id=000000 transaction_id=3152913560
msg=“device-keys updated” dev_eui=551e06feffe5a0cc
msg=“js: sending response” message_type=JoinAns receiver_id=000000 result_code=Success sender_id=aabbccddeeff1122 transaction_id=3152913560
msg=“js: request received” message_type=JoinReq receiver_id=aabbccddeeff1122 sender_id=000000 transaction_id=3771167499
msg=“device-keys updated” dev_eui=551e06feffe5a0cc
msg=“js: sending response” message_type=JoinAns receiver_id=000000 result_code=Success sender_id=aabbccddeeff1122 transaction_id=3771167499
msg=“js: request received” message_type=JoinReq receiver_id=aabbccddeeff1122 sender_id=000000 transaction_id=2909086288
msg=“device-keys updated” dev_eui=551e06feffe5a0cc
msg=“js: sending response” message_type=JoinAns receiver_id=000000 result_code=Success sender_id=aabbccddeeff1122 transaction_id=2909086288

and log for my gateway is
level=info msg=“gateway: rxpk packet received” addr=“192.168.0.31:57580” data=“ACIR/+7dzLuqzKDl//4GHlW8/lWVcNQ=” mac=7276ff0039030a65
level=info msg=“backend: publishing packet” qos=0 topic=gateway/7276ff0039030a65/rx
level=info msg=“backend: downlink packet received” topic=gateway/7276ff0039030a65/tx
level=error msg=“gateway: could not handle packet: invalid character ‘\x00’ looking for beginning of value” addr=“192.168.0.31:58353” data_base
level=info msg=“gateway: rxpk packet received” addr=“192.168.0.31:57580” data=“ACIR/+7dzLuqzKDl//4GHlUoe72XfOY=” mac=7276ff0039030a65
level=info msg=“backend: publishing packet” qos=0 topic=gateway/7276ff0039030a65/rx
level=info msg=“backend: downlink packet received” topic=gateway/7276ff0039030a65/tx
level=info msg=“gateway: stat packet received” addr=“192.168.0.31:57580” mac=7276ff0039030a65
level=info msg=“backend: publishing packet” qos=0 topic=gateway/7276ff0039030a65/stats
level=error msg=“gateway: could not handle packet: invalid character ‘\x00’ looking for beginning of value” addr=“192.168.0.31:58353” data_base


#2

It’s look that you have wrong fre config on gateway.
Do you install lora-gateway-bridge on the gateway?


#3

yes
from ther
https://www.loraserver.io/lora-gateway-bridge/gateway/kerlink/


#4

Please show this file: /mnt/fsuser-1/spf/etc/global_conf.json and gateway bridge config


#5

sory but i cant find this file on my gateway the config file in my gateway in user/spf/global_conf.json and
the server is connected with my server ip and port is 1700 also the gateway bridge is connected to my server ip and i see on server app dashbord the gate way is connected and i have downlink and uplink but
no live dive comming