Add Network Server to lora-gateway-os


#1

Hi everyone,
I’m trying to setup my first LoRa Gateway with the latest (test4) lora-gateway-os-full image on my RPi 3.

I’m able to login to the UI, but I can’t add a network server. I get the message context deadline exceeded (code: 2) when I try to add my server localhost:8000.

Is the network-server installed on this image by default? Where do I find the logs?

I really would appreciate any help :slight_smile:.

Regards,
Friedemann

p.s. In my console there is a message Id "S0" respawning too fast: disabled for 5 minutes. Does this part of the problem?


#2

Maybe this helps?

raspberrypi3:~$ sudo /opt/lora-packet-forwarder/lora_pkt_fwd
*** Beacon Packet Forwarder for Lora Gateway ***
Version: 4.0.1
*** Lora concentrator HAL library version info ***
Version: 5.0.1;
***
INFO: Little endian host
ERROR: [main] failed to find any configuration file named global_conf.json, local_conf.json OR debug_conf.json
raspberrypi3:~$ 

Edit: I’m using an IC880a and an external power supply with 3A.
Edit2: Ok, I was running the command from the wrong directory :innocent:
Edit3: Now I was able to add the Network server. Is this a bug?


#3

Please note that the first time it might take some time before all the components are fully initialized. Therefore LoRa Server might still have been in the initialization state (e.g. applying the PostgreSQL migrations).


#4

i read that. But how long does it take? More than 40 minutes?


#5

A couple of minutes.


#6

Yes, indeed. I was too impatient :innocent: