Received phyPayload and Error while receiving data


#1

Hello People,

hope you’re having a wonderful day.

So far I managed to setup everything and receive data from my device, the Elsys.se ERS sound.
However I have a few questions about that.

I receiver phyPayload, which for my understanding, is the information I want but have to decrypt. But compared to others in this forum it looks weird:

“phyPayload”:“QHWFKQAAxQCku0FfJuVUFSbHhDlHsHP0DSbOQJw=”

Is this how its supposed to look like?

I also have some erros and could need help. Here the full log:

gateway/7276ff000b0311fa/rx {“rxInfo”:{“mac”:“7276ff000b0311fa”,“time”:“2019-03-15T07:11:31Z”,“timestamp”:596802652,“frequency”:868500000,“channel”:7,“rfChain”:1,“crcStatus”:1,“codeRate”:“4/5”,“rssi”:-46,“loRaSNR”:8,“size”:29,“dataRate”:{“modulation”:“LORA”,“spreadFactor”:12,“bandwidth”:125},“board”:0,“antenna”:0},“phyPayload”:“QHWFKQAAxQCku0FfJuVUFSbHhDlHsHP0DSbOQJw=”}
application/1/device/a81758fffe038954/error {“applicationID”:“1”,“applicationName”:“loraapplication”,“deviceName”:“ERSsound”,“devEUI”:“a81758fffe038954”,“type”:“CODEC”,“error”:“js vm error: ReferenceError: ‘Decode’ is not defined”,“fCnt”:197}

I’m thankful for any advice or help. Thanks in advance.

Have great day!


#2

It mean that you set in lora-app-server this:


But your’s decode function is empty (like in screenshot), if you change codec to none this error has gone


#3

I deleted it afterwards and did a restart. I’ll try what you said. This would be only a solution for now, since I need to decode my payload. But how can I make it manually before I invest time for the code. I’m new to JS. Really new…


#4

Do you have decode instructions?
I use this site: https://cryptii.com/pipes/text-to-base64
I decode base 64 to bytes. After that I use device packet instruction to check what info i receive.


#5

Thank you very much. I don’t have decode instructions. I’ll have a look at it now. Thank you!


#6

If you’re going to use the JS codec, the bytes parameter is the actual bytes array, it’s not base64 encoded, so you don’t need to decode it to bytes first.


#7

Ok. So now I get this data:

AQDpAiQEAMIFAAcN5xVQLg==

and when I try to decode on that given website it gives me an error:

Invalid UTF-8 encoded text: Continuation byte expected at 0x3

I’ve checked all troubleshoots, to make sure everything else is working, and as far as I can tell it does. So how can I make this readable?

I’m sorry for my “noob” questions. I’m seriously new to this, without any knowledge in Java or whatsoever. Somehow I managed to make this all work and came to this point and if someone could help me, that would be great.

Thanks in advance!


#8

See https://play.golang.org/p/Xi8h_GkbsSK for a decode example.


#9

Just want to say thank you very much to everyone who helped me with this. After almost 2 weeks I managed to set this up and receive information from one device. This was so much fun to me. I learned a lot and I will keep learning since this is just the beginning.

Thank you so much everyone!