OTAA failed / Debugging device activation OTAA issues


#23

I don’t think so, in this link https://www.st.com/content/st_com/en/products/embedded-software/mcus-embedded-software/stm32-embedded-software/stm32cube-expansion-packages/i-cube-lrwan.html you can see that from I-CUBE-LWAN_V1.1.0 the lorawan mac version used is V1.0.3.

You can also find a previous link which deals about this topic ==> https://forum.loraserver.io/t/lorawan-mac-version-1-0-3/1914

In my case I’m using I-CUBE-LWAN_V1.0.x (it works with loraserver) and I notified the same behavior with I-CUBE-LWAN_V1.1.0 that is to say join-request/accept loop.


#24

Setting the device-profile to LoRaWAN 1.0.2 or 1.0.3 should not matter for LoRa Server as the only change in behavior of LoRa Server is between 1.0.x vs 1.1.x.


#25

Yes I understand your point of view, normally with lorawan mac V1.0.3 implementation only class B devices could encounter an issue, but something is different from the release of I-CUBE-LRWAN_V1.1, certainly we have to get closer of STMicroelectronics to go deeper.


#26

Julien, is the example code version you are using still available to download? I can’t find it anywhere.

Also, may I PM you about something.


#27

Only the latest version is available from www.st.com but fortunately for you :wink: I have the .zip of I-CUBE-LRWAN_V.1.0.5 which work with lorawan mac version 1.0.2, if you are interested I can send you by email through google drive link.


#28

@Gal @julien please note that there already is a v1.2.0 version of I-CUBE-LRWAN. Maybe that is worth trying?


#29

I did try that version and after setting the connection data in commissioning.h and downloading it to my MCU nothing came through.


#30

In fact, I have the same problem as you, whether the problem is solved now or not.


#31

It is not resolved. I am using ABP whenever I need to test something.


#32

Hello brocaar,
Why have I tried all the LoraWAN MAC versions and still have a join-request join-accept loop?