Multitec Conduit 915 Mhz Change sub band (channels)


#1

Hi, I have a Multiconnect conduit gateway already working with the lora server. I have created an application in the "lora server app" and i can add devices, also i can see received data in the "live device data" and “live lorawan frames” tabs of the "application/devices" option in the server. So everything is working just fine.

But there´s a problem I can´t solve, I have two gateways profiles, both were created with channels 0-7 but now I want to change one gateway profile to be in the channel plan from 8 to 15 (second sub band), nevertheless i can´t do it. Obviously I have also changed the channels in my devices (lora nodes rn2903). There´s an strange behavior in the MultiConnect Conduit as i can´t see the log file “/var/log/lora-gateway-bridge/lora-gateway-bridge.log”, also i can´t see nothing in the MQTT topics using these commands:

  • List item mosquitto_sub -v -t gateway/+/rx
  • List item mosquitto_sub -v -t gateway/+/config

Nevertheless I know the packet forwarding is working because i can see the data in the lora server app. There another fact, I also have a Rapsberry Pi 3 with a RAK831 Gateway running and it´s working perfectly, I have another aplication in the lora server app configured for this gateway. The Raspberry Pi let me run the command “journalctl -f -n 100 -u lora-gateway-bridge” (I can´t run this command on conduit because systemctrl and journal are not installed on Multiconnect), the output of this command shows me a warning message about the configuration, it says: “configuration was not applied, gateway is not configured for managed configuration”.

Also, I know the lora server is sending the configurations to the gateways becouse when i run "mosquitto_sub -v -t gateway/+/config" I get this output:

Blockquote
gateway/00800000a0001a6e/config {“mac”:“00800000a0001a6e”,“version”:“2018-09-21T01:53:25.891747Z”,“channels”:[{“modulation”:“LORA”,“frequency”:903900000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:904100000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:904300000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:904500000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:904700000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:904900000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:905100000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:905300000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]}]} gateway/b827ebfffe2db98e/config {“mac”:“b827ebfffe2db98e”,“version”:“2018-09-20T17:16:23.226271Z”,“channels”:[{“modulation”:“LORA”,“frequency”:902300000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:902500000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:902700000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:902900000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:903100000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:903300000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:903500000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]},{“modulation”:“LORA”,“frequency”:903700000,“bandwidth”:125,“spreadingFactors”:[7,8,9,10]}]}

The gateway 00800000a0001a6e (Multitech) is trying to be configured in the second sub band and the gateway b827ebfffe2db98e (RAK831) is trying to be configured in the first sub band.

My first clue is that maybe mosquitto need a more advanced configuration. I´m not sure about it. If mosquitto has to be configurated in each gateway and has to be configurated in the loraserver host, how can i do it? Can you show me an example?. If mosquitto is not the problem, then what is going on?

Thanks in advance.


#2

As the Conduit has limited storage space, no logs are written. You could stop the lora-gateway-bridge and start it manually. E.g.:

/etc/init.d/lora-gateway-bridge-stop
/opt/lora-gateway-bridge/lora-gateway-bridge --config /var/config/lora-gateway-bridge/lora-gateway-bridge.toml

Without any modifications, any client is able to publish / subscribe to any topic, so unless you have made modifications (e.g. created Mosquitto ACLs), then this should not be the issue.

Did you update your lora-gateway-bridge.toml config file to support the gateway-profiles configuration? https://www.loraserver.io/lora-app-server/use/gateways/#gateway-profiles


#3

Ok, I’m almost ready with the configuration, but I have an issue becouse I don´t find local_conf.json file in the Multiconnect Conduit gateway lora-packet-forwarder-usb configured using this installation instructions.

I don’t know how to set the output_file option in the lora bridge configuration file (/var/config/lora-gateway-bridge/lora-gateway-bridge.toml).


#4

Ok, I’m almost ready with the configuration, but I have an issue becouse I don´t find local_conf.json file in the Multiconnect Conduit gateway lora-packet-forwarder-usb configured using this installation instructions.

I don’t know how to set the output_file option in the lora bridge configuration file (/var/config/lora-gateway-bridge/lora-gateway-bridge.toml) .


#5

The packet-forwarder will read two files:

  1. First global_conf.json
  2. Then local_conf.json (if it exist), overriding changes in global_conf.json

When 2. does not exist, only the global_conf.json configuration is applied. In the case of the LoRa Gateway Bridge, the output_file will point to the not yet existing local_conf.json file as it will be generated for you :slight_smile:


#6

Thank you, ir already works!