Lora Gateway OS not booting with out HDMI or keyboard


#1

Hi,
I’ve installed the Lora gateway os basic on a Raspberry Pi but it does not seem to boot when there is no HDMI or Keyboard plugged in.
If either one or both are plugged in I can ssh in to the Pi on its static IP. If neither are plugged in either the Pi doesn’t boot or the networking doesn’t start but either way I can’t see the IP. Tried nmap etc…

Any ideas?

EDIT:
I now have the Pi working with a USB wifi dongle attached. The Pi is being used as a wired device so not too much of an issue but it would still be nice to know why this is happening as I will be building some more gateways.


#2

Were you able to resolve it?

I have the same problem . I tried setting to level 3 as default for inittab but it didnt work


#3

I configured the ethernet port, which is how the Pi is connected to the network, no WiFi, and the gateway is booting fine.

eg
sudo connmanctl services

sudo connmanctl config ethernet_6ceceb5cc4c3_cable --ipv4 manual 192.168.12.210 255.255.255.0 192.168.12.254