Is this LoRaServer compatible with RAK831

Will this Server setup work on the RAK831 hardware ?

One way to confirm this. If you look on the RAK site you will see the RAK2245 can be run in three different configurations. One is with running on the Raspberry Pi.

And see also this overview: :slight_smile:

I had some troubles with getting LoRaServer-OS from Brocaar operating on a RAK-831 pilot gateway.
This gateway has an adapter board with GPS on it between the RPi and RAK831 board.

I installed LoraServer-OS on two of these devices and it mostly appears to function except that the sensor nodes did not hear or receive the joinAccept from the gateway.

It was the typical joinRequest joinAccept loop many have had troubles with.

I was pulling my hair out thinking it was the library used on the Feather M0 board, from mcci-catena. I tried alternative libraries and the problem persisted.

So, I ended up installing Debian Stretch headless and then from RAK Wireless GitHub, their implementation of LoRaGateway for RAK831/RAK2245, which installs LoRaServer.

This then worked first go and the thing I like about it is it is standard Debian and I can update using standard methods.

One thing, the gateway-config from Brocaar is slightly better thought out than from RAKWireless.

I don’t know why the LoRaServer-OS had troubles, but suspect it might come down to a GPIO pin assignment for reset or something similar. Something for me to re-look into at some point as I just need the the packet forwarder and gateway bridge to integrate into a larger LoRaWAN network.


Thank you, been trying to set up a RAK831 Pilot Gateway for a while now. After many undocumented modifications, 2 different hardware nodes worked for it intermittently. But, I’m going to give your method a shot.

Thanks for this idea. I’m also having the same issues with the gateway-os on an rpi3b+ with ral831.
Will try the debian + rakwireless implementation.

Any further thoughts on why we experienced the join request loops?