Incorrect channel mask and data-rate in mac commands


#1

The loraserver isn’t configuring the enabled uplink channels and requested data rate in my device correctly. I am using the US band, and in the loraserver.toml config file I set the enabled channels to:

enabled_uplink_channels=[0,1,2,3,4,5,6,7]

and in my gateway profile configuration in the Lora app server UI, I also set the enabled channels to 0,1,…,7. In my service profile I set both the minimum and maximum allowed data-rates to 0. However, in the “Live Lorawan Frames” section for my device, it looks like the mac downlink command is enabling the first 16 channels and data rate 4:

And in the loraserver log, it shows that it is enabling all 72 channels in my device:

loraserver[18483]: time="2018-10-05T17:42:25Z" level=info msg="link_adr request acknowledged" dev_eui=647fda00xxxxxxxx dr=4 enabled_channels="[0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71]" nb_trans=1 tx_power_idx=1

Any advice is appreciated. Thanks.


#2

Are you sure you did restart LoRa Server after changing the configuration?


#3

face palm I did forget to restart Loraserver and that fixed the channel config issue. Thanks!

I also played around more with the max/min data rate settings in the service profile. If the max and min are different values like min=0, max=1 for example, then Loraserver uses dr=1 for the max. But if they are both set to 0 then loraserver seems to ignore them altogether.