Gateway discovery documentation


#21

I have started using the new bridge and found that two gateways that work fine send an ack after transmission:

gateway/0031552048001a06/tx
{"txInfo":{"mac":"0031552048001a06","immediately":true,"timestamp":0,"frequency":867100000,"power":14,"dataRate":{"modulation":"LORA","spreadFactor":7,"bandwidth":125},"codeRate":"4/5","iPol":false,"board":0,"antenna":0},"phyPayload":"4PCKoUY="}

gateway/0031552048001a06/ack
{"mac":"0031552048001a06","token":0}

gateway/0031552048001a03/tx
{"txInfo":{"mac":"0031552048001a03","immediately":true,"timestamp":0,"frequency":867100000,"power":14,"dataRate":{"modulation":"LORA","spreadFactor":7,"bandwidth":125},"codeRate":"4/5","iPol":false,"board":0,"antenna":0},"phyPayload":"4EBznTU="}

gateway/0031552048001a03/ack
{"mac":"0031552048001a03","token":0}

The other 5 gateways are running on resin.io but these gateways do not reply with a ack.

So, data is sent by LoRaAppserver but not handled by the multi packet forwarder that runs on resin.io.

Any ideas?


#22

I might not have mentioned it in the documentation, but the ACK feature is only available for packet-forwarder versions using the v2 protocol. The protocol-version of your gateway is printed in the LoRa Gateway Bridge logs.


#23

I will look in to it. please hold the line :slight_smile:


#24

Sorry to bump an old topic, but does this still hold? I can’t seem to find where to configure the gateway discovery feature.


#25

Note that you also need to enable this globally in lora-app-server.toml


#26

Damn, just missed that, I thought they were part of the general conf. On the same note, I can’t find anything related to gateway discovery on the lora-app-server.conf, and I checked internal/config/config.go to make sure it wasn’t just missing from the file.


#27

Oh actually, that might be the only configuration :slight_smile: This was refactored a while ago and it used to be in lora-app-server.toml. Only, this did not work out as when adding multiple network-servers for different regions the config had to match the network-server band, which is the reason why it is now under network-servers.


#28

Ha, I was never gonna find it :laughing:.

Thanks!


#29

Hello @brocaar

My lora-app-server config file added in /etc/lora-app-server

but i getting issue with gateway ping

so i need to move config file under /etc/default/lora-app-server ?

Thanks


#30

When you configure the ping settings in the LoRa App Server, does the App server send the configuration to the gateways via the gateway bridge and then over UDP over the same UDP port as the regular LoRa messages? Or is there a different protocol/port for these sort of messages?


#31

The pings are schedule using LoRa Server using this API method: https://github.com/brocaar/loraserver/blob/master/api/ns/ns.proto#L90.