Failed to start LoRa Server


#21

I setup an instance of Debian 9 on an old Dell 1950 to use as a LoRa server. Everything went fine with the install and all services are running except for loraserver which comes up with a “status=1/failure”


#22

Did you check the log output? See https://www.loraserver.io/loraserver/install/debian/ for the commands to view the log output.


#23

Yes, this is what is says in repeat. There is no loraserver.log file as of yet because the server has not started yet. so this is the partial output of journalctl.

Oct 14 06:53:20 masterserver systemd[1]: loraserver.service: Main process exited, code=exited, status=1/FAILURE
Oct 14 06:53:20 masterserver systemd[1]: loraserver.service: Unit entered failed state.
Oct 14 06:53:20 masterserver systemd[1]: loraserver.service: Failed with result ‘exit-code’.
Oct 14 06:53:20 masterserver systemd[1]: loraserver.service: Service hold-off time over, scheduling restart.
Oct 14 06:53:20 masterserver systemd[1]: Stopped LoRa Server.


#24

Alternatively you can start LoRa Server from the CLI if not all the logs are collected:

sudo -u loraserver loraserver -c /etc/loraserver/loraserver.toml

#25

Well this helps get me a little closer. When starting it that way I get the following error:
FATA[0000] get band config error: lorawan/band: band US_902_928 is undefined

So obviously something wrong with the config. IS there a full sample config file for US installs?


#26

Now that I’m looking at it a bit more closely it is saying that the band is undefined. Where would that be referenced? Did I unknowingly miss an install step? Everything else comes up positive and the database is running as well. Just can’t figure out where this reference is from.

EDIT:[SOLVED - FOR ME] - in looking through the code I had a realization that the band name was in quotes and I thought, “That would be a lot of work to put error correction in there if someone left in an asterix or something.” So I we to my config and foudn that I had an extra space before US so it was " name=" not “name=”

Such a simple fix and it only took two days for me to find it. lol, I knew it was something silly like that.


#27

Great you got it solved :slight_smile:

(and you’ll find a config sample in the documentation: https://www.loraserver.io/guides/debian-ubuntu/#us915-configuration-example)