Error: device-session does not exist or invalid fcnt or mic


#22

Not analog data, data is uploaded by real devices.





#23

@tfssweb

Are you using ABP? you also reset the frame-counters at the device. Because of this, LoRa Server rejects these frames as it could as well be a replay-attack. To work around this, you could check the Disable frame-counter validation box (on ABP activation).

@tfssweb Set 1.0.2 LoRaWAN MAC version


#24

Yes, I’ve banned it, but there’s still the problem; another problem is that I’m configured to OTAA and I can’t receive data at all, no matter what.


I’ve basically looked at all the topics related to this issue in the forum, but they haven’t been solved yet. I hope you can help me. Thank you.


#25

@tfssweb
Please check LoRaWAN Mac Version (v1.0.2) in device-profile


#26

Yes, I used 1.0.2.


#27

For LoRaWAN 1.1 devices, the network session key is replaced by network session encryption key, serving network session integrity key and forwarding network session integrity key” so these values are the same. of topic how you log the left values (loraserver, gatewaybridge, redis, etc)


#28

Hi

i receive this error my sensor trys to join.

I had this issue with another sensor and changing the application key to from LSB to MSB was able to fix it for me

but the things mentioned here do not seem to work for the other sensor

The sensor that i cannot get to join
Has lorawan mac version 1.02
And is OTAA

I have tried disable frame counter
I have also tried MSB and LSB for the application key

Is there anything else i am missing that can fix this issue

This device was working with the previous version of the loraserver.io

Thanks
Johnjoe