Downlink TX frequency is 0


#1

Getting an issue when i send a downlink packet using the lora-app-server api.
i’m using the server version 2.3.0
I found that the packet is rejected at the gateway due to freq:0 parameter


#2

Without more information like your loraserver.toml configuration, device-profile configuration etc… I’m unable to help you.


#3

Sir,

Device profile configuration:
1)GENERAL
LoRaWAN MAC version * 1.0.1
LoRaWAN Regional Parameters revision * A
2) JOIN (OTAA/ABP)
Supports OTAA = FALSE (i.e does not supports otaa)
RX2 data-rate * 2
3) Class-C
Device supports class C

ONLY WORKING WITH ABP in CLASS C

loraserver.toml contents:

[general]

log_level=4

[postgresql]
dsn="postgres://loraserver_ns:dbpassword@localhost/loraserver_ns?sslmode=disable"

automigrate=true

[redis]
url="redis://localhost:6379"

max_idle=10
idle_timeout="5m0s"

[network_server]
net_id="000000"

deduplication_delay="600ms"
device_session_ttl="8760h0m0s"
get_downlink_data_delay="100ms"

  [network_server.band]
  name="IN_865_867"

  dwell_time_400ms=false

  repeater_compatible=false

  [network_server.network_settings]

  installation_margin=10

 
  rx_window=0
  rx1_delay=1
  rx1_dr_offset=0
  rx2_dr=-1
  rx2_frequency=-1
  downlink_tx_power=-1
  disable_mac_commands=false
  disable_adr=true
  enabled_uplink_channels=[]


  [network_server.network_settings.class_b]
  ping_slot_dr=0
  ping_slot_frequency=0



  [network_server.network_settings.rejoin_request]
  enabled=false

 
  max_count_n=0
  max_time_n=0


 
  [network_server.scheduler]
   scheduler_interval="1s"

    [network_server.scheduler.class_c]
 
    downlink_lock_duration="2s"


  [network_server.api]
  bind="0.0.0.0:8000"

  [network_server.gateway.stats]
  create_gateway_on_stats=true

  timezone=""
  aggregation_intervals=["minute", "hour", "day"]

  [network_server.gateway.backend]
    type="mqtt"
    uplink_topic_template="gateway/+/rx"
    downlink_topic_template="gateway/{{ .MAC }}/tx"
    stats_topic_template="gateway/+/stats"
    ack_topic_template="gateway/+/ack"
    config_topic_template="gateway/{{ .MAC }}/config"

    server="tcp://localhost:1883"
    qos=0
    clean_session=true


   uplink_retention_duration="24h0m0s"

server="http://localhost:8003"

#4

@brocaar sir,

I’ve updated you with the configurations.

This issue begins to happen when I updated my loraserver, lora-app-server and lora-gateway-bridge to the latest release, also i’ve installed lora-geo-server, but not using it now.


#5

From your information, I get that you left the RX2 frequency to 0 in the device-profile:

You should update it to the correct frequency and re-activate the device.


#6

Yes, sir i’ve updated the RX2 frequencies!
And will update you soon for the same whether it worked or not.

Thank you!


#7

Still getting the same issue, downlink tx frequency in some of the device downlink is found to be 0(zero).
RX2 frequency is 866550000 this time and also added the other frequencies, but still getting tx freq ZERO.