Decoding Nasys pulse reader payload


#1

we use matchx gateway and think the built there cloude platform on loraserver somthing it look’s like that.

and then we try new sensors from nasys.no but we get strange sensordata.

And contact at nasys say this:

But more likely is that the data is still encrypted and need to be decrypted before the payload can be parsed. This we have seen before in some systems.

But for me it feel strange and al most impossible … we get data and what we can see it look’s good… but get strange sensordata.

Have any one see this behaviour???


#2

I don’t think anybody is able to help you if you don’t share what exact data you received and what data you expected.


#3

My quistion to nasys:

we working to check all other node’s. but we still have problem battery ran out of power and will not work any more.

Then we started new puls sensor and what we can see this to send very strange data. will check and dubbel check other node’s and get back to you. you say somthing that it can be so that payload is not decrypted and you se this with som other products.This feel strange if this is so, we got this matchx lora gateway and we use there portal for all of our products. Do you have any exampel of products that have that problem?

Think matchx platform is loraserver so if you can give us some exampel where you have se this vould be very nice.

This is what we got from nasys in the latest respons:

Regarding where i’ve seen this. Currently can’t find any reference on quick browse (have thousands of email in my inbox to search trough). But if i remember correctly it has been some version of the loraserver.io

Cannot be 100% tho, as i do not have access to any solution running it at the moment. And this may not be the case at the moment, as it might have been fixed or improved. But there have been couple of client that have somehow separately decoding the packages.

Or was it some basic free lorawan provider that had this going on.

In any case it is easy to check. if all the other nodes data is perfectly decodable as is and there are no configuration difference on server side, then this is the fault of the node. (but this would be the first case for the pulse reader. again this doew not mean it’s not possible).

here is document for puls reader:

here are some payloads on fport 24 that is temp and battery status and some more:

payload: jan 8 “DjN3K4K9Fa61pV/3/HU=”
payload: jan 9 “MHKWyIcN2lOjGlQeN3g=”
payload: jan 10 “OV4AjGz5bzwRTH96qfU=”
payload: jan 11 “q+soKpX4mqWrjkEpm0k=”
payload: jan 12 “4uHBG8wIVgNqo1arMgg=”
payload: jan 13 “CaWW+V/MxGKxf+vUnYw=”

we started to build debugtool for decoding (not ready jet) can use fport 24 and nasys to debug payloads
http://lorawandebug.rays.se/

hope some one have some god input to this problem and can help us…

Thanks in advance


#4

I’m not going to build a full decoder for you, but you might have made some mistakes in your debugtool. See the output of https://play.golang.org/p/UnULSM7eiGy

Vs what you tool is outputting:

Note for example that the temperature is a int8, you’re displaying a uint8. Also I get a different RSSI in my output.


#5

Thank’s that may one of the problem and for sure we can be wrong, we are littel new to lora and lorawan.

will verify…

Thankful for all the help!