Configuring Multicast


#1

We are using the latest firmware for our devices, which makes them Class C and multicast capable. After creating the multicast-group via the loraserver’s web app and setting the correct values for the mcastdevaddr, mcastnwkskey, and mcastappskey, I tried to POST a message to that multicast group using the API.

I got a 200 response code, and I’m able to see (via the Live Lorawan Frames) that the downlinks are leaving the gateway heading out for the correct mcastdevaddr, but my devices are not detecting them either on the Live Device Data or Live Lorawan Frames.

I have reset the frame counter on both the device and the multicast-group, though it’s my understanding that if it were the frame counter, I would see the Live Lorawan Frames coming in on the device, but not on the Live Device Data.

I have also ensured that since I am using Class C, I have sent an initial uplink so that the loraserver has the information it needs to send downlinks (and have tested single-cast downlinks, which work correctly).

Is there something that I’m missing or doing incorrectly that would explain why I am not seeing the multicast data on the device?


#2

You won’t see the multicast frames in the web-interface under the device as they are not sent to each device individually. They only appear under the gateway LoRaWAN frames.


#3

Problem solved. I had been trying to use multicast with dr 0, when I should have been using it with dr 8 (since it’s a downlink).