Configuring end device different channel set


#1

Hello,
I have a 8 channel gateway on the US915 region. I have two devices, both OTAA, each on a different set of channels. I would like to configure one to switch to the other set of channels, so they are both on the same set. How would I enable this functionality? Is the functionality for this device specific? I came across this thread but this seems to focus on the EU region. [[network_server.network_settings.extra_channels]] is an option but I would like the device to only work within the specific channel sub band, after join attempts on the entire 64 channel uplink spread. Any explanation would be helpful.Thanks for your time.


#2

See:

  # Enable only a given sub-set of channels
  #
  # Use this when ony a sub-set of the by default enabled channels are being
  # used. For example when only using the first 8 channels of the US band.
  # Note: when left blank, all channels will be enabled.
  #
  # Example:
  # enabled_uplink_channels=[0, 1, 2, 3, 4, 5, 6, 7]
  enabled_uplink_channels=[]

https://www.loraserver.io/loraserver/install/config/


#3

So what I understand its that you have the server well configured (as Brocaar said) but you have to devices that are configured on a different sub set of channels and the gateway only supports 8.

The problem in 915 is that CFList does not exist, so devices do not know which subset needs to be used. In EU we have 3 fixed channels, and then CFList tells us wich 5 channels we have to use. That are the extra channels in the other post

I don’t really know if there is an automatic process to select channels in 915, what we do is sell devices that can change the subset with a configurator so the client can select what subset of 915 want.


#4

An US915 device should try all channels for OTAA. This means that initially there will be some packet loss, but after a successful OTAA, LoRa Server will use the mac-commands to communicate the enabled channels (enabled_uplink_channels) to the device, which should match the channels to which your gateways are configured :slight_smile:


#5

Well, last time I tried this it did not work, but that was around one year ago.

RisingHf devices seems to want the channels configured before anything at least in the version I was trying for 915