Change default tx power


#1

Hi guys!

I’m trying to configure the tx power, but it seems that with the last server version it’s no possible anymore. Everything is configured with/by ADR.

But when i’m trying to walk away of the gateway, the tx power never changes in the frame logs.
And the ADR flag is set by the device.

So, is it possible to set the tx power to increase the gateway range?

Thanks,

Mathis


#2

This was never possible. For the gateway LoRa Server always uses the default band TX Power as defined in https://github.com/brocaar/lorawan/tree/master/band.

This would be a nice addition to add to the loraserver.toml configuration file. Best would be to create an issue https://github.com/brocaar/loraserver so I can keep track of the feature requests. Of course if you would be able to make a pull-request adding this that would be great :slight_smile:


#3

Dear brocaar
Hi
I clone the “https://github.com/brocaar/lorawan” in my lora server , my gateway frequency is 868MHz. So I want to use https://github.com/brocaar/lorawan/blob/master/band/band_eu863_870.go
I want to set TXPower to 20 dB.
func (b *eu863Band) GetDownlinkTXPower(freq int) int {
return 14
}
I don’t know how I can use this .go file, if I run this .go file, TX power will change to 20 dB?


#4

You can configure this in the loraserver.toml file :slight_smile:


#5

Hey Brocaar we are trying to set “downlink_tx_power” in the loraserver.toml file to configure our GW’s TX power (Tektelic Macro in this case). Can you clarify what the units are for this parameter? Do we enter:

downlink_tx_power=28 (to program for 28dBM) -or-
downlink_tx_power=1 (are we supposed to use the enumeration from the power table in Regional Paramters)

Thanks,
Patrick

Following is from the .toml file comments for reference:

Downlink TX Power (dBm)

When set to -1, the downlink TX Power from the configured band will
be used.

Please consult the LoRaWAN Regional Parameters and local regulations
for valid and legal options. Note that the configured TX Power must be
supported by your gateway(s).
downlink_tx_power=-1


#6

Downlink TX Power (dBm)

dBm :wink: