Can not connect to web-interface from external machine / LoRa App Server not listening on public interface


#1

I Have bought a seperate server based on linux environment with a unique I.P address. Lora Server and Lora-app-server has been configured.But I seem to be having a problem when i run the gui on windows. Hence if i want to configure the loraserver gui in my IP address of the server instead of localhost. Could you please shine some light on the solution???


#2

Then you need to use https://PUBLIC-IP-OF-YOUR-SERVER:8080/ :wink:


#3

Do i have to change the bind Parameters in config files also… if yes which ones?


#4

I have done the same. And i get the following error:


#5

When all the components are running on the same server, you would still use localhost. You only have to point your browser to the IP of your server :wink:


#6

I tried that man… It says site refused to connect


#7

Waitng for your response


#8

Please check your logs, check the services are running on your server, check the ports to which they are binding etc…


#9

Hi I have check for the runnin services. seems to me that every darn this running,

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 10029/mysqld
tcp 0 0 127.0.0.1:6379 0.0.0.0:* LISTEN 21244/redis-server
tcp 0 0 127.0.0.1:8081 0.0.0.0:* LISTEN 4331/lora-app-serve
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1532/sshd
tcp 0 0 127.0.0.1:5432 0.0.0.0:* LISTEN 307/postgres
tcp 0 0 127.0.0.1:5433 0.0.0.0:* LISTEN 325/postgres
tcp 0 0 0.0.0.0:1883 0.0.0.0:* LISTEN 22821/mosquitto
tcp 0 0 127.0.0.1:8000 0.0.0.0:* LISTEN 3818/loraserver
tcp 0 0 127.0.0.1:8001 0.0.0.0:* LISTEN 4331/lora-app-serve
tcp6 0 0 :::8009 :::* LISTEN 10326/java
tcp6 0 0 :::8080 :::* LISTEN 10326/java
tcp6 0 0 :::22 :::* LISTEN 1532/sshd
tcp6 0 0 :::1883 :::* LISTEN 22821/mosquitto
tcp6 0 0 :::8002 :::* LISTEN 3818/loraserver
tcp6 0 0 127.0.0.1:8005 :::* LISTEN 10326/java

What do you think??


#10

Aug 29 12:02:04 ubuntu-1gb-blr1-01 loraserver[5898]: time=“2017-08-29T12:02:04Z” level=info msg=“transport: http2Client.notifyError got notified that the client transport was broken EOF.”

I am also getting this log above in loraserver:what does this mean?


#11

Could you post your LoRa App Server configuration (without credentials / secrets)?


#12
### # postgresql dsn (e.g.: postgres://user:password@hostname/database?sslmode=disable) (default: "postgres://localhost/loraserver?sslmode=disable")
POSTGRES_DSN=postgres://{Username}:{Password}@localhost/{Database name}?sslmode=disable

###  #automatically apply database migrations
DB_AUTOMIGRATE=true

###  #redis url (e.g. redis://user:password@hostname/0) (default: "redis://localhost:6379")
REDIS_URL=redis://localhost:6379

###  #mqtt server (e.g. scheme://host:port where scheme is tcp, ssl or ws) (default: "tcp://localhost:1883")
MQTT_SERVER=tcp://localhost:1883

###  #mqtt server username (optional)
MQTT_USERNAME={MQTT username}

###  #mqtt server password (optional)
MQTT_PASSWORD={MQTT password}

###  #ca certificate used by the api server (optional)
CA_CERT=
###  #tls certificate used by the api server (optional)
TLS_CERT=

###  #tls key used by the api server (optional)
TLS_KEY=

###  #ip:port to bind the api server (default: "0.0.0.0:8001")
BIND=localhost:8001

###  #ip:port to bind the (user facing) http server to (web-interface and REST / gRPC api) (default: "0.0.0.0:8080")
HTTP_BIND= localhost:8080

###  #http server TLS certificate
HTTP_TLS_CERT=/etc/lora-app-server/certs/http.pem

###  #http server TLS key
HTTP_TLS_KEY=/etc/lora-app-server/certs/http-key.pem

###  #JWT secret used for api authentication / authorization
### You could generate this by executing 'openssl rand -base64 32' for example
JWT_SECRET={Generated using 'openssl rand -base64 32' }

###  #hostname:port of the network-server api server (default: "127.0.0.1:8000")
NS_SERVER=localhost:8000

###  #ca certificate used by the network-server client (optional)
NS_CA_CERT=

###  #tls certificate used by the network-server client (optional)
NS_TLS_CERT=

###  #tls key used by the network-server client (optional)
NS_TLS_KEY=

###  #the number of iterations used to generate the password hash
PW_HASH_ITERATIONS=100000

###  #debug=5, info=4, warning=3, error=2, fatal=1, panic=0
LOG_LEVEL=4

#13

HTTP_BIND= localhost:8080

There you go, when you bind to localhost, the service will not be listening on any public interface. Change this to 0.0.0.0:8080 in order to make the service listen on all interfaces.


#14

Hi brocaar, Thanks a lot man. Without you none of this would be possible…You are super intelligent


#15

brocaar ,Thanks a lot man,Thank you very much, you are our mentor!


#16

where is the LoRa App Server configuration.I want to change ip and port,how to change.