Can Lora server force ADR to be on?


#1

I was under the impression that if you disable ADR on a node it was disabled for good:
I’m getting some weird behaviour where the Spreading Factor is constantly cycling upwards from 7 to 10 and then looping back to 7. On the node I’m forcing SF7.

This is one part of the gateway log, it shows the node sending a confirmed uplink with adr off, but the corresponding downlink from loraserver has the adr flag enabled.

Notably when I enable ADR on the node, I’m stuck at SF12 (DR_0) and the datarate doesn’t optimize itself downward but the ADR flag on the downlink ack doesn’t have the adr flag enabled.

edit: Hmm, I seem to be getting MIC failures on the node when operating in lorawan 1.1 which could explain that the datarates were cycling due to transmission retries, but does it explain why downlinks get the adr flag set?

when operating in lorawan 1.0.3 everything works as it should.


#2

This might explain it:


#3

Ah, yeah.

That would explain it. Thanks.